Resolved
This incident has been resolved.
Monitoring
We have deployed an additional remediation for our cross-region failover to increase job-launch throughput while AWS instance capacity is limited. Early signs are showing fewer capacity errors, but we are continuing to monitor the situation.
Identified
We are continuing to see capacity issues across us-east-1 and us-east-2 inside of AWS. While this is ongoing, we are rerouting jobs to AZs in regions with capacity. We are in contact with AWS to get additional capacity in the impacted regions released.
This degraded performance is only impacting GitHub Actions runners to date.
Investigating
We are investigating reports of increased queue time for x86 Ubuntu GitHub Actions jobs.