Increased queue time for GitHub Actions jobs, increased API error responses
Resolved·Partial outage

This incident has been resolved.

Tue, Oct 28, 2025, 09:18 PM
(1 week ago)
·
Affected components
API
Updates

Resolved

This incident has been resolved.

Tue, Oct 28, 2025, 09:18 PM

Monitoring

Queue times for GitHub Actions jobs have returned to normal. API failures affecting container builds and the container registry have also stopped. We will continue to monitor for a fully recovery.

Tue, Oct 28, 2025, 09:06 PM(12 minutes earlier)

Monitoring

AWS have confirmed an outage of the use1-az2 zone - we have determined that this has been affecting network traffic to our API service, causing API requests that were randomly routed through Amazon's load balancer in that zone to fail to reach the API service. We have routed API traffic out of the affected zone and are seeing a recovery of API request errors.

Tue, Oct 28, 2025, 08:58 PM

Identified

We continue to see increased queue times for GitHub Actions jobs, though many jobs are able to process.

We also continue to see an increase in responses from our API and are working to resolve.

Tue, Oct 28, 2025, 08:37 PM(21 minutes earlier)

Monitoring

We have increased capacity for Actions runner jobs to process the backlog.

We have also observed some API request failures when requesting to start a container build, we have deployed additional API capacity and expect retrying the failed build requests to succeed.

Tue, Oct 28, 2025, 07:16 PM(1 hour earlier)

Monitoring

We continue to see elevated queue times for depot-ubuntu-24.04 jobs.

Tue, Oct 28, 2025, 06:03 PM(1 hour earlier)

Monitoring

We are still observing increased queue times for depot-ubuntu-24.04 jobs as the backlog of incoming jobs is processed.

Tue, Oct 28, 2025, 04:55 PM(1 hour earlier)

Monitoring

AWS is experiencing an incident in a single availability zone, we have routed all GitHub Actions jobs away from the affected zone and are monitoring.

Tue, Oct 28, 2025, 04:34 PM(21 minutes earlier)