Resolved
This incident has been resolved.
Monitoring
We have deployed a fix to address the delays and are monitoring to ensure everything remains healthy.
Investigating
We are investigating increased delays when starting container builds and GitHub Actions jobs