Depot - Latency in starting jobs and container builds – Incident details

Latency in starting jobs and container builds

Resolved
Degraded performance
Started 4 days agoLasted 15 minutes

Affected

Container builds

Degraded performance from 7:10 PM to 7:22 PM, Operational from 7:22 PM to 7:25 PM

us-east-1

Degraded performance from 7:10 PM to 7:22 PM, Operational from 7:22 PM to 7:25 PM

eu-central-1

Degraded performance from 7:10 PM to 7:22 PM, Operational from 7:22 PM to 7:25 PM

us-west-2

Degraded performance from 7:10 PM to 7:22 PM, Operational from 7:22 PM to 7:25 PM

GitHub Actions

Degraded performance from 7:10 PM to 7:25 PM

Depot-managed Actions Runners

Degraded performance from 7:10 PM to 7:25 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved and queue times for -latest labels are in the normal ranges again.

  • Monitoring
    Monitoring

    We have identified the problem and implemented a fix for those runner labels. We are monitoring queue times to verify they are in the expected range.

  • Update
    Update

    We have identified additional latency in starting depot-ubuntu-latest and depot-ubuntu-24.04 GitHub Actions runners. We are investigating whether the same latency exists in container builds.

  • Investigating
    Investigating
    We are currently investigating this incident.