Depot - Website and API outage – Incident details

Website and API outage

Resolved
Major outage
Started 12 days agoLasted 20 minutes

Affected

Container builds

Major outage from 9:11 PM to 9:15 PM, Partial outage from 9:15 PM to 9:31 PM

us-east-1

Major outage from 9:11 PM to 9:15 PM, Partial outage from 9:15 PM to 9:31 PM

eu-central-1

Major outage from 9:11 PM to 9:15 PM, Partial outage from 9:15 PM to 9:31 PM

GitHub Actions

Major outage from 9:11 PM to 9:15 PM, Partial outage from 9:15 PM to 9:31 PM

Depot-managed Actions Runners

Major outage from 9:11 PM to 9:15 PM, Partial outage from 9:15 PM to 9:31 PM

API

Major outage from 9:11 PM to 9:15 PM, Degraded performance from 9:15 PM to 9:31 PM

Updates
  • Resolved
    Resolved

    Build service has fully restored.

  • Update
    Update

    Build and Action jobs are starting to process, we are working through the backlog of jobs from the disruption.

  • Identified
    Identified

    We have deployed a mitigation and are seeing service begin to be restored.

  • Investigating
    Investigating

    We are currently investigating an API and website outage.