Depot - Increased queue times for GitHub Actions jobs – Incident details

Increased queue times for GitHub Actions jobs

Resolved
Partial outage
Started 4 days agoLasted about 1 hour

Affected

GitHub Actions

Partial outage from 9:44 PM to 9:47 PM, Operational from 9:47 PM to 10:48 PM

Depot-managed Actions Runners

Partial outage from 9:44 PM to 9:47 PM, Operational from 9:47 PM to 10:48 PM

Github.com - Actions

Updates
  • Resolved
    Resolved

    The system continues to behave as expected and the incident is now resolved.

  • Monitoring
    Monitoring

    As of 21:47 UTC we disabled a feature flag that controlled the faulty provisioning system functionality. The system has now stabilized and jobs are processing normally.

    We will continue to monitor for any further issues.

  • Investigating
    Investigating
    We are currently investigating this incident.