Depot - Degraded performance when starting Docker and GitHub Actions builds – Incident details

Degraded performance when starting Docker and GitHub Actions builds

Resolved
Partial outage
Started 4 months agoLasted about 3 hours

Affected

Container builds

Degraded performance from 2:03 PM to 3:08 PM, Partial outage from 3:08 PM to 4:27 PM, Degraded performance from 4:27 PM to 5:27 PM

us-east-1

Degraded performance from 2:03 PM to 3:08 PM, Partial outage from 3:08 PM to 4:27 PM, Degraded performance from 4:27 PM to 5:27 PM

GitHub Actions

Operational from 2:03 PM to 3:08 PM, Partial outage from 3:08 PM to 4:27 PM, Degraded performance from 4:27 PM to 5:27 PM

Depot-managed Actions Runners

Operational from 2:03 PM to 3:08 PM, Partial outage from 3:08 PM to 4:27 PM, Degraded performance from 4:27 PM to 5:27 PM

API

Degraded performance from 2:03 PM to 3:08 PM, Partial outage from 3:08 PM to 4:27 PM, Operational from 4:27 PM to 5:27 PM

Website

Operational from 2:03 PM to 3:08 PM, Partial outage from 3:08 PM to 4:27 PM, Operational from 4:27 PM to 5:27 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are seeing queue times return to normal, we're continuing to monitor

  • Identified
    Identified

    We have identified a database issue preventing builds from starting, we are working to resolve the issue.

  • Investigating
    Investigating

    We are investigating an issue causing longer queue times when starting Docker and GitHub Actions builds