Depot - GitHub Outage – Incident details

GitHub Outage

Resolved
Partial outage
Started 3 months agoLasted about 3 hours

Affected

GitHub Actions

Degraded performance from 4:17 PM to 4:33 PM, Partial outage from 4:33 PM to 7:02 PM

Depot-managed Actions Runners

Degraded performance from 4:17 PM to 4:33 PM, Partial outage from 4:33 PM to 7:02 PM

Github.com - Actions

Updates
  • Resolved
    Resolved

    GitHub jobs are processing normally.

  • Monitoring
    Update

    We are still seeing some increased job queue times, but the backlog of jobs is processing.

  • Monitoring
    Monitoring

    GitHub have marked their incident as closed, but we have not yet seen full recovery of Actions webhooks. We will continue to monitor as they recover.

  • Identified
    Update

    GitHub is now reporting a general outage, including for git operations: https://www.githubstatus.com/incidents/88003ngctf1z

  • Identified
    Identified

    We are currently observing increased delays receiving GitHub job webhooks from GitHub, which may cause increases in the queue times for some jobs, or may cause the Depot UI to incorrectly display jobs as queued when they have actually started running. We will continue to monitor.