Depot - GitHub Webhook Delay – Incident details

GitHub Webhook Delay

Resolved
Degraded performance
Started about 2 months agoLasted 22 minutes

Affected

GitHub Actions

Degraded performance from 10:51 PM to 11:12 PM

Depot-managed Actions Runners

Degraded performance from 10:51 PM to 11:12 PM

Updates
  • Resolved
    Resolved

    The webhook delay seems to be resolved.

  • Investigating
    Investigating

    We're currently investigating delayed GitHub webhooks, causing increased GitHub Actions job queue times. GitHub appears to be sending webhooks with as high as a 6-minute delay from the job queue time.