Depot - Increased GitHub job queue time – Incident details

Increased GitHub job queue time

Resolved
Partial outage
Started about 2 months agoLasted about 6 hours

Affected

GitHub Actions

Degraded performance from 5:48 PM to 6:25 PM

Depot-managed Actions Runners

Degraded performance from 5:48 PM to 6:25 PM

Github.com - Actions

Updates
  • Resolved
    Resolved

    GitHub have marked the incident as resolved.

  • Monitoring
    Update

    We are observing all jobs able to successfully start. GitHub is still reporting that status updates are delayed for all Actions customers. https://www.githubstatus.com/incidents/nj47vccwm2zj

  • Monitoring
    Monitoring

    While GitHub are still investigating the incident, we are seeing some jobs able to complete, though their status is often not reflected correctly in the GitHub UI. https://www.githubstatus.com/incidents/nj47vccwm2zj

  • Identified
    Update

    GitHub have identified the cause as network connectivity issues on their end, they are continuing to investigate: https://www.githubstatus.com/incidents/nj47vccwm2zj

  • Identified
    Update

    GitHub have just opened an incident of their own for this outage: https://www.githubstatus.com/incidents/nj47vccwm2zj

  • Identified
    Update

    This appears to be a GitHub Actions outage - both GitHub-hosted runners and Depot-hosted runners are currently experiencing issues starting jobs.

  • Identified
    Identified

    We are observing GitHub taking an increased amount of time to release Actions jobs to runners.