Depot - GitHub Actions outage – Incident details

GitHub Actions outage

Resolved
Partial outage
Started 2 months agoLasted about 1 hour

Affected

GitHub Actions

Degraded performance from 4:48 AM to 5:32 AM

Depot-managed Actions Runners

Degraded performance from 4:48 AM to 5:32 AM

Github.com - Actions

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    GitHub has opened an outage of its own that we are now monitoring https://www.githubstatus.com/incidents/2bglpcjvg7xb

  • Identified
    Identified

    We have identified the issue as being on GitHub's end. They are either not releasing jobs in a timely manner to online runners or not sending webhook events when jobs are in progress. We will continue to monitor queue times on our side.

  • Investigating
    Investigating
    We are currently investigating this incident.