Depot - GitHub Actions Outage – Incident details

GitHub Actions Outage

Resolved
Degraded performance
Started 3 months agoLasted about 2 hours

Affected

GitHub Actions

Degraded performance from 6:51 PM to 8:35 PM, Operational from 8:35 PM to 8:36 PM, Degraded performance from 8:36 PM to 8:36 PM

Depot-managed Actions Runners

Degraded performance from 6:51 PM to 8:35 PM, Operational from 8:35 PM to 8:36 PM, Degraded performance from 8:36 PM to 8:36 PM

Updates
  • Resolved
    Resolved

    GitHub has cleared their outage but we are continuing to monitor slower webhook delivery times from their side.

  • Identified
    Identified

    GitHub Actions is currently having an outage that is degrading performance across all of Actions. We are monitoring: https://www.githubstatus.com/incidents/xcjgp37zx5dt