Resolved
Queue times have returned to normal. This incident has been resolved.
Identified
GitHub published an incident indicating that they were having issues delivering webhooks in a timely manner. They have indicated that the root cause has been mitigated. We will continue to monitor queue times.
https://www.githubstatus.com/incidents/4yz3c18qmdxn
Investigating
We are investigating alerts about elevated queue time for GitHub Actions jobs