Resolved
Mitigation is deployed, this incident has been resolved.
Identified
We are working with our database provider to deploy a mitigation for the increased read-replica lag.
Investigating
We are investigating alerts about high replication lag on Depot's primary database.