Resolved
The upstream provider has restored service, analytics are available in the dashboard again.
Identified
We have identified this as caused by an upstream provider outage in us-east-1. We will monitor the progress of that incident.
Investigating
We are investigating an issue impacting our analytics storage cluster. Analytics and usage pages are failing to load.