Increased queue times for Actions jobs
Resolved·Degraded performance

Queue times have returned to normal for those runner types. It appears to have only impacted high-volume GitHub Actions orgs and appears to be the fallout of the GitHub Actions outage reported earlier today: https://www.githubstatus.com/incidents/crd2y6xy6knn

Tue, Jul 1, 2025, 06:20 AM
(1 month ago)
·
Affected components
Updates

Resolved

Queue times have returned to normal for those runner types. It appears to have only impacted high-volume GitHub Actions orgs and appears to be the fallout of the GitHub Actions outage reported earlier today: https://www.githubstatus.com/incidents/crd2y6xy6knn

Tue, Jul 1, 2025, 06:20 AM

Monitoring

We have implemented a workaround caused by the GitHub outage that is causing extended queue times for 8 & 16 CPU runners. We are monitoring the results and checking on queue times across the system.

Tue, Jul 1, 2025, 06:11 AM

Identified

We have identified the root cause as the GitHub Actions outage they had earlier. We have reduced the blast radius of long queue times to 8 and 16 core CPU runners for Ubuntu 24.04. We are working to bring that runner type back within normal queue times.

Tue, Jul 1, 2025, 05:58 AM(13 minutes earlier)

Identified

We've identified the cause of the issue, and are working on a fix.

Tue, Jul 1, 2025, 01:22 AM(4 hours earlier)

Investigating

We are currently investigating an increase in queue times for some Actions jobs.

Mon, Jun 30, 2025, 10:00 PM(3 hours earlier)