Long queue times / failures for Actions jobs
Resolved·Partial outage

All jobs are processing normally, we are no longer seeing GitHub errors.

Wed, May 28, 2025, 04:55 PM
(2 months ago)
·
Affected components
GitHub.com
Updates

Resolved

All jobs are processing normally, we are no longer seeing GitHub errors.

Wed, May 28, 2025, 04:55 PM

Monitoring

We are seeing a reduction of errors from GitHub and an increase in successful jobs processing. We will continue to monitor.

Wed, May 28, 2025, 04:27 PM(28 minutes earlier)

Monitoring

While some jobs are processing, many are still failing. Upstream GitHub appears to still be returning errors from their API. We are continuing to monitor.

Wed, May 28, 2025, 04:01 PM(26 minutes earlier)

Investigating

We are investigating long queue times / failures to start some Actions jobs.


This may be related to GitHub's recently-closed outage: https://www.githubstatus.com/incidents/l5jqk83qnfzd.

Wed, May 28, 2025, 04:01 PM

Identified

This appears to have been caused by a GitHub rate limit reached during the outage. We are beginning to see jobs processing again and are monitoring progress.

Wed, May 28, 2025, 02:55 PM(1 hour earlier)