Depot - GitHub Actions outage – Incident details

GitHub Actions outage

Resolved
Major outage
Started about 1 month agoLasted about 2 hours

Affected

GitHub Actions

Degraded performance from 4:50 AM to 7:15 AM

Depot-managed Actions Runners

Degraded performance from 4:50 AM to 7:15 AM

Github.com - Actions

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    GitHub has opened an incident that we are monitoring: https://www.githubstatus.com/incidents/v677w7xlvkss

  • Identified
    Identified

    GitHub Actions appears to be undergoing a major outage, preventing jobs from being triggered. For jobs that can be triggered, the control plane is not releasing them to online runners.

    We are continuing to monitor the situation and waiting for a status update from GitHub.

  • Investigating
    Investigating

    We are investigating GitHub Actions queue times being longer than expected.