Depot - Container builds and GitHub jobs failing to start – Incident details

Container builds and GitHub jobs failing to start

Resolved
Operational
Started about 1 month agoLasted about 1 hour

Affected

Container builds

Major outage from 5:58 PM to 6:26 PM, Operational from 6:26 PM to 6:44 PM

us-east-1

Major outage from 5:58 PM to 6:26 PM, Operational from 6:26 PM to 6:44 PM

eu-central-1

Major outage from 5:58 PM to 6:26 PM, Operational from 6:26 PM to 6:44 PM

GitHub Actions

Major outage from 5:58 PM to 6:31 PM, Degraded performance from 6:31 PM to 6:44 PM

Depot-managed Actions Runners

Major outage from 5:58 PM to 6:31 PM, Degraded performance from 6:31 PM to 6:44 PM

Github.com - Actions

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have identified the issue impacting GitHub Actions jobs and are monitoring recovery.

  • Identified
    Identified

    Container builds are back online in both regions.

  • Investigating
    Update

    We are currently investigating two issues simultaneously. One is impacting container builds starting in a timely matter. The other is related to GitHub Actions jobs not starting. We are diagnosing both.

    GitHub is also reporting an outage related to Actions: https://www.githubstatus.com/incidents/y0gqch2dhw5l

  • Investigating
    Investigating
    We are currently investigating this incident.