Depot - GitHub Actions outage – Incident details

GitHub Actions outage

Resolved
Major outage
Started 2 months agoLasted about 1 hour

Affected

GitHub Actions

Major outage from 5:09 PM to 5:52 PM, Partial outage from 5:52 PM to 6:37 PM

Depot-managed Actions Runners

Major outage from 5:09 PM to 5:52 PM, Partial outage from 5:52 PM to 6:37 PM

Github.com - Actions

Updates
  • Resolved
    Resolved

    GitHub is reporting that they have completed recovery. We are seeing all jobs able to start - if you have any jobs that are still queued, you may need to cancel and re-try them.

  • Monitoring
    Monitoring

    GitHub has started recovering some of the delayed webhooks, and we are seeing some Actions jobs able to start now. We'll continue to monitor as GitHub completes recovery.

  • Identified
    Identified

    We are investigating reports of GitHub jobs queued, but not yet sent from GitHub to Depot.

    GitHub reports issues delivering webhooks: https://www.githubstatus.com/incidents/5yx1d67vq9hg