Issues starting builds in us-east-1

Resolved
Partial outage
Started 2 months ago Lasted 33 minutes

Affected

Builds
API
Updates
  • Resolved
    Resolved

    We've rolled out a fix, and all builds are recovering. We will continue to monitor.

  • Monitoring
    Monitoring

    We are rolling out a fix and monitoring recovery.

  • Identified
    Identified

    We've identified an issue with API latency that is causing builds to take longer than usual to start.

  • Investigating
    Investigating

    We are currently investigating delays in machines launching for builds in us-east-1.