Depot - Some API requests failing – Incident details

Some API requests failing

Resolved
Partial outage
Started 11 days agoLasted 4 minutes

Affected

Container builds

Partial outage from 2:47 PM to 2:52 PM

us-east-1

Partial outage from 2:47 PM to 2:52 PM

eu-central-1

Partial outage from 2:47 PM to 2:52 PM

GitHub Actions

Degraded performance from 2:47 PM to 2:52 PM

Depot-managed Actions Runners

Degraded performance from 2:47 PM to 2:52 PM

API

Partial outage from 2:47 PM to 2:52 PM

Updates
  • Resolved
    Resolved

    This appears to have been a brief network disruption for our database provider that has since recovered, all jobs and builds are processing normally again.

  • Investigating
    Investigating

    We are currently investigating reports of API request failing, preventing container builds from starting and increasing queue times for GitHub Actions jobs.