Depot - macOS runners failing to launch – Incident details

macOS runners failing to launch

Resolved
Degraded performance
Started 19 days agoLasted about 3 hours

Affected

GitHub Actions

Degraded performance from 11:57 AM to 2:30 PM

Depot-managed Actions Runners

Degraded performance from 11:57 AM to 2:30 PM

Updates
  • Resolved
    Resolved

    Build service is restored. The underlying cause was an issue with a certificate / system time in the macOS VM image itself. We have deployed a working image to all macOS hosts.

  • Monitoring
    Monitoring

    We are currently deploying a fix to all macOS hosts, build service is beginning to be restored.

  • Identified
    Identified

    We have identified the potential root cause and are working on populating a fix out across the fleet of compute for macOS runners.

  • Investigating
    Investigating

    We are currently investigating an issue with macOS runners for GitHub Actions not launching.