Depot - Failing to launch builders – Incident details

Failing to launch builders

Resolved
Partial outage
Started almost 2 years agoLasted about 4 hours

Affected

Container builds

Partial outage from 1:33 PM to 5:22 PM

us-east-1

Partial outage from 1:33 PM to 5:22 PM

API

Partial outage from 1:33 PM to 5:22 PM

Updates
  • Resolved
    Resolved

    We have rolled out a fix across our API to improve performance.

  • Monitoring
    Monitoring

    We have rolled out a temporary fix to improve API performance while we implement a final fix.

  • Identified
    Identified

    We have identified and rolled out a fix to restore builders coming online. We continue to investigate API performance issues in acquiring a builder for multiple concurrent build requests.

  • Investigating
    Investigating

    We are currently investigating a performance issue within our API that is causing builders to fail to launch.