Depot - GitHub Incident – Incident details

GitHub Incident

Resolved
Degraded performance
Started 12 days agoLasted about 2 hours

Affected

GitHub Actions

Operational from 6:18 PM to 7:53 PM

Depot-managed Actions Runners

Operational from 6:18 PM to 7:53 PM

Github.com - Actions

Updates
  • Resolved
    Resolved

    Job delivery times have been stable since GitHub marked their incident as resolved.

  • Update
    Update

    GitHub has indicated that they've applied a mitigation, and we're observing that jobs are once again arriving in a timely manner. We'll continue to monitor.

  • Monitoring
    Monitoring
    It appears that GitHub is able to deliver jobs with increased queue times in the range of 10+ seconds. We'll continue to monitor.
  • Investigating
    Investigating

    GitHub is currently experiencing an incident causing degraded performance and increased queue times.