Depot - Depot CLI downloads are unavailable – Incident details

Depot CLI downloads are unavailable

Resolved
Partial outage 0
Started 10 days agoLasted about 1 hour

Affected

API

Partial outage from 3:09 PM to 3:32 PM, Degraded performance from 3:32 PM to 4:36 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved, CLI downloads are functional again.

  • Monitoring
    Monitoring

    We have deployed a workaround to bypass the GitHub outage / rate limit, we are monitoring.

  • Identified
    Identified

    Due to a GitHub outage, the depot CLI is unable to be downloaded from GitHub releases. This is blocking the ability of the depot/setup-action to download the CLI from Actions jobs, whether they are Depot-hosted or GitHub-hosted.