Depot - Long queue times / failures for Actions jobs – Incident details

Long queue times / failures for Actions jobs

Resolved
Degraded performance
Started 20 days agoLasted about 2 hours

Affected

GitHub Actions

Degraded performance from 2:55 PM to 4:55 PM

Depot-managed Actions Runners

Degraded performance from 2:55 PM to 4:55 PM

Updates
  • Resolved
    Resolved

    All jobs are processing normally, we are no longer seeing GitHub errors.

  • Update
    Update

    We are seeing a reduction of errors from GitHub and an increase in successful jobs processing. We will continue to monitor.

  • Monitoring
    Monitoring

    While some jobs are processing, many are still failing. Upstream GitHub appears to still be returning errors from their API. We are continuing to monitor.

  • Identified
    Identified

    This appears to have been caused by a GitHub rate limit reached during the outage. We are beginning to see jobs processing again and are monitoring progress.

  • Investigating
    Investigating
    We are investigating long queue times / failures to start Windows Actions jobs. This may be related to GitHub's recently-closed outage: .