Depot - Increased queue times for GitHub Actions – Incident details

Experiencing partially degraded performance

Increased queue times for GitHub Actions

Resolved
Partial outage
Started about 1 month agoLasted about 3 hours

Affected

GitHub Actions

Degraded performance from 6:19 AM to 7:30 AM, Partial outage from 7:30 AM to 9:44 AM

Depot-managed Actions Runners

Degraded performance from 6:19 AM to 7:30 AM, Partial outage from 7:30 AM to 9:44 AM

Github.com - Actions

Updates
  • Resolved
    Resolved

    GitHub are reporting that the incident is resolved.

  • Update
    Update

    GitHub is still working to resolve the incident: https://www.githubstatus.com/incidents/9yk1fbk0qjjc

  • Update
    Update

    GitHub has now opened an incident for Actions: https://www.githubstatus.com/incidents/9yk1fbk0qjjc

  • Monitoring
    Monitoring

    This is an outage inside of GitHub Actions where jobs are not being delivered to online runners. We are continuing to monitor the situation and waiting for an update from GitHub.

  • Identified
    Identified

    We have identified that this appears to be related to an issue with GitHub delivering jobs to online runners. We are continuing to see if we can work around their issue.

  • Investigating
    Investigating

    We are currently investigating increased queue times for GitHub Actions.