Depot - Possible GitHub Actions outage – Incident details

Possible GitHub Actions outage

Resolved
Degraded performance
Started about 1 month agoLasted about 1 hour

Affected

GitHub Actions

Github.com - Actions

Updates
  • Resolved
    Resolved

    This outage appears to have resolved

  • Identified
    Identified

    GitHub Actions seems to currently be experiencing an outage where some workflows are stuck in a queued state and / or never launch jobs. Additionally, some of these workflows are unable to be canceled.

    If it's possible to re-trigger the workflow (new commit, new run, etc), the issue appears to be intermittent.

  • Investigating
    Investigating

    We are currently investigating reports that GitHub Actions is experiencing an outage / is queuing jobs indefinitely.