Depot - Monitoring GitHub outage – Incident details

Monitoring GitHub outage

Resolved
Degraded performance
Started 3 months agoLasted about 5 hours

Affected

GitHub Actions

Degraded performance from 11:11 AM to 4:21 PM

Depot-managed Actions Runners

Degraded performance from 11:11 AM to 4:21 PM

Updates
  • Resolved
    Resolved

    GitHub has cleared their outage, but we are monitoring webhook delivery times from their side.

  • Monitoring
    Monitoring

    We are still monitoring webhook flakiness due to the ongoing GitHub outage: https://www.githubstatus.com/incidents/7txcg0j03kkg. This is surfacing as longer than normal queue times while we wait for GitHub to pass the job to an online runner.

  • Identified
    Identified

    We are actively monitoring the ongoing GitHub outage that is impacting GitHub Actions: https://www.githubstatus.com/incidents/7txcg0j03kkg