Depot - Database outage – Incident details

Database outage

Resolved
Partial outage
Started 6 months agoLasted about 1 hour

Affected

Container builds

Degraded performance from 2:29 PM to 2:49 PM, Partial outage from 2:49 PM to 2:51 PM, Degraded performance from 2:51 PM to 3:31 PM

us-east-1

Degraded performance from 2:29 PM to 2:49 PM, Partial outage from 2:49 PM to 2:51 PM, Degraded performance from 2:51 PM to 3:31 PM

GitHub Actions

Degraded performance from 2:29 PM to 2:49 PM, Partial outage from 2:49 PM to 2:51 PM, Degraded performance from 2:51 PM to 3:31 PM

Depot-managed Actions Runners

Degraded performance from 2:29 PM to 2:49 PM, Partial outage from 2:49 PM to 2:51 PM, Degraded performance from 2:51 PM to 3:31 PM

API

Operational from 2:29 PM to 2:49 PM, Partial outage from 2:49 PM to 3:31 PM

Website

Operational from 2:29 PM to 2:49 PM, Partial outage from 2:49 PM to 3:31 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Update

    We've gotten our database provider to clear the outage on their side. We're monitoring initial recovery.

  • Identified
    Update

    We've identified the cause as an outage at our database provider, we are working to restore service.

  • Identified
    Identified

    We've identified a performance degradation at our upstream database provider that we are working with them on.

  • Investigating
    Investigating

    We are currently investigating an issue causing increased latency when starting GitHub Actions and container builds.