Depot - Slow GitHub webhook delivery – Incident details

Slow GitHub webhook delivery

Resolved
Partial outage
Started 7 months agoLasted about 1 hour

Affected

GitHub Actions

Degraded performance from 8:29 AM to 9:43 AM, Partial outage from 9:43 AM to 9:56 AM

Depot-managed Actions Runners

Degraded performance from 8:29 AM to 9:43 AM, Partial outage from 9:43 AM to 9:56 AM

Updates
  • Resolved
    Resolved

    We've fixed the underlying runner issue following the GitHub Actions outage. We are observing full recovery and will continue monitoring.

  • Identified
    Update

    We're investigating runners still failing to start following the GitHub Actions outage.

  • Identified
    Identified

    GitHub Actions is currently experiencing degraded performance: https://www.githubstatus.com/incidents/5ly0psff2s5d